Recent Tutorials
Who is online?
In total there are 9 users online :: 0 Registered, 0 Hidden and 9 Guests :: 2 Bots

None

[ View the whole list ]


Most users ever online was 172 on Fri 19 Feb 2016, 05:17
Keywords

[Bug] The theme selector with Firefox

View previous topic View next topic Go down

avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Sun 29 Jan 2017, 01:55

Hello @Ange Tuteur ,
I have a worry with Firefox regarding the theme selector, overfly we no longer see the background background whereas with Chrome there is no problem.
Please note that Firefox is up to date with version: 51.0.1.
Here is the link of the forum in question with a recent installation without modification:

http://testdesforums.1fr1.net/

Thank you in advance

a++


Last edited by Milouze14 on Wed 22 Feb 2017, 23:43; edited 1 time in total
avatar
Valoish
Graphic Designer
Title :
Gender : Female
Age : 20
Posts : 3618
Points : 4616
Reputation : 348
Location : NYC
Language : English, Russian, Hebrew
Browser : Browser : Opera Forum Version : Forum Version : phpBB2
Awards :
View all awards
View user profile http://www.canvasforums.com https://twitter.com/https://twitter.com/Valoishx3

PostValoish on Sun 29 Jan 2017, 06:24

This issue was already brought up earlier. Unfortunately it isn't a bug with Ange's code so there's nothing he can do on his side.. Mozilla is gonna have to fix the bug on their side with updates to the browser

--------

"I was afraid. And my own insecurity crushed him." - Youku x Boku SS
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Sun 29 Jan 2017, 13:13

Hello,
It is amazing because I did not have this bug before the last update of Firefox.
I will therefore wait for this browser to face an update Wink .

a++
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Mon 30 Jan 2017, 10:36

The problem seems to be related to both hardware ( computer ) and software ( Firefox ), because for example on my computer the theme selector options are colorized, but if I go onto another computer the options are NOT colorized. To be honest it's confusing, that's why I opened this ticket with some alternate ideas for the theme selector if Mozilla never fixes the issue. xD
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Mon 30 Jan 2017, 12:46

Hello Ange Tuteur,
thank you for the reply,i will wait for the future update of firefox ...

a++
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Tue 31 Jan 2017, 10:40

Same here, hopefully they'll remedy the issue soon.. Tap
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Mon 20 Feb 2017, 01:56

Hello @Ange Tuteur,
Have you modified the script recently because under Firefox the background is displayed again, no browser update, can be Windows?

a++
avatar
SLGray
Valued Member
Title :
Owner of 2 Forums
Gender : Male
Age : 44
Posts : 2364
Points : 4549
Reputation : 280
Location : United States
Language : English
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : ModernBB
Awards :
View all awards
View user profile http://www.fmthemes.forumotion.com https://www.facebook.com/FM-Themes-655055824604957 https://twitter.com/FMThemes https://pinterest.com/FMThemes

PostSLGray on Mon 20 Feb 2017, 14:12

@Milouze14 wrote:Hello @Ange Tuteur,
Have you modified the script recently because under Firefox the background is displayed again, no browser update, can be Windows?

a++
It is not fixed for me.
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Mon 20 Feb 2017, 22:14

Hello,



a++
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Wed 22 Feb 2017, 12:19

@Milouze14 wrote:Hello @Ange Tuteur,
Have you modified the script recently because under Firefox the background is displayed again, no browser update, can be Windows?

a++
Did you change computers recently ? I didn't send out any updates, so this change can only be from the user's end. Think
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Wed 22 Feb 2017, 13:30

No, otherwise I would have mentioned, it becomes mysterious this story Very Happy .

a++
avatar
Dr Jay

Title :
Power of Youth!
Gender : Male
Posts : 153
Points : 486
Reputation : 33
Location : USA
Language : English (Native)
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.geekpolice.net

PostDr Jay on Wed 22 Feb 2017, 19:39

Those involved here that still have trouble...

-Check for Windows Updates
-Sync Firefox and refresh your profile. If it happens with other browsers than Firefox, let me know.
-Check for graphics card updates.
-Disable hardware acceleration in your browsers.

=> Let me know if resolved.

--------

~Dr Jay
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Thu 23 Feb 2017, 12:27

@Dr Jay wrote:Those involved here that still have trouble...

-Check for Windows Updates
-Sync Firefox and refresh your profile. If it happens with other browsers than Firefox, let me know.
-Check for graphics card updates.
-Disable hardware acceleration in your browsers.

=> Let me know if resolved.
Thanks for posting this information. I'm gonna check this on my other computer when I get the chance.
avatar
Dr Jay

Title :
Power of Youth!
Gender : Male
Posts : 153
Points : 486
Reputation : 33
Location : USA
Language : English (Native)
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.geekpolice.net

PostDr Jay on Thu 23 Feb 2017, 12:55

Right on... I do hope that many graphics card manufacturers ship updates soon, because of the Windows 10 Creators Update coming soon. During that update, they will be refreshing the Windows UI again, and this will likely create even more graphics trouble.

--------

~Dr Jay
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Fri 24 Feb 2017, 12:50

I made a few tests, but to no avail. It does make me wonder if it could be linked to graphic cards.. Think

These are the two I'm using on separate computers :
- NVIDIA GeForce 6150SE nForce 430 ( theme selector is colored )
- Intel(R) HD Graphics ( theme selector isn't colored )

Then again it might not be, because it changed outta nowhere for Milouze. This whole thing has been way over my head. Whistle
avatar
Dr Jay

Title :
Power of Youth!
Gender : Male
Posts : 153
Points : 486
Reputation : 33
Location : USA
Language : English (Native)
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.geekpolice.net

PostDr Jay on Fri 24 Feb 2017, 13:06

Well, this is no surprise, as some have had this trouble even with other sites... it's one of those things...

example: http://www.tomshardware.com/forum/41999-42-javascript-working-browser

--------

~Dr Jay
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Fri 24 Feb 2017, 13:27

Haha yeah, there has been an inconsistency with the display of content between browsers and hardware for years... especially during the IE days. It can all get complicated fast. x.x They have a ticket for the display inconsistencies of the <select> tag on bugzilla, which is still active.
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Fri 24 Feb 2017, 13:41

Hello @Ange Tuteur ,
Hello, I do not think this is connected with with a device.

My post is on :20 February 2017:
http://fmdesign.forumotion.com/t1248-bug-the-theme-selector-with-firefox#29478

On the other hand, I see in Firefox modules (Webdevelopper )that an update (20 February 2017) has been made and that corresponds to the correct display of the select




a++
avatar
Dr Jay

Title :
Power of Youth!
Gender : Male
Posts : 153
Points : 486
Reputation : 33
Location : USA
Language : English (Native)
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.geekpolice.net

PostDr Jay on Fri 24 Feb 2017, 13:46

Ha WebKit... well, that's a mess right there. If it's a WebKit problem, it's definitely not something we can look into. Workarounds are fine for some, but for most others, unlikely to solve the issue. Too many properties in WebKit require explicit declaration.

You know what... This is interesting... Many of the browsers use the native dropdown from Windows... Is it possible that some people's Windows OS causing issues with dropdown functionality on styling? Would the theme selector be clickthrough or fully native?

--------

~Dr Jay
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Fri 24 Feb 2017, 13:48

Hmm.. that's interesting. I'll check that out when I get on my other computer again.

Also there's a very recent comment from the ticket that I mentioned :
Julien Cristau wrote:2017-02-23
If this needs to be fixed in 52, it has to be really soon now, we're building the last beta before RC today. Or should this be deferred to 53?
So perhaps a fix will be made in 52 or 53 at the latest. Think
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4652
Points : 9634
Reputation : 2327
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Fri 24 Feb 2017, 13:52

@Dr Jay wrote:You know what... This is interesting... Many of the browsers use the native dropdown from Windows... Is it possible that some people's Windows OS causing issues with dropdown functionality on styling? Would the theme selector be clickthrough or fully native?
I was also thinking this in the beginning. ( e.g. differences in win8, 7, 10 ) However, some people on the same version of the OS seem to have the issue, while others do not. It also seems to be a Firefox exclusive issue. Both of my PCs are running win10, but show the select element differently. Confused
avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Fri 24 Feb 2017, 14:26

I have just uninstalled the web developer extension and hop the select again as before, it is enough to give this extension and it is again in function

a++
avatar
SLGray
Valued Member
Title :
Owner of 2 Forums
Gender : Male
Age : 44
Posts : 2364
Points : 4549
Reputation : 280
Location : United States
Language : English
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : ModernBB
Awards :
View all awards
View user profile http://www.fmthemes.forumotion.com https://www.facebook.com/FM-Themes-655055824604957 https://twitter.com/FMThemes https://pinterest.com/FMThemes

PostSLGray on Fri 24 Feb 2017, 15:59


avatar
Milouze14

Title :
Gender : Male
Age : 51
Posts : 76
Points : 390
Reputation : 22
Location : French Vendée
Language : French
Browser : Browser : Mozilla Firefox Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile http://www.milouze14.com/

PostMilouze14 on Fri 24 Feb 2017, 21:21


Hi,
With this extension: Web Developer:
http: http://chrispederick.com/work/web-developer/

The select is:


If I delete this extension:



View previous topic View next topic Back to top

Create an account or log in to leave a reply

You need to be a member in order to leave a reply.

Create an account

Join our community by creating a new account. It's easy!


Create a new account

Log in

Already have an account? No problem, log in here.


Log in

 
Permissions in this forum:
You cannot reply to topics in this forum