Latest topics
» Auto-suggest @mentions as You Type
by skouliki Today at 04:57

» Hello everyone this is Adam from France
by SLGray Today at 01:09

» FM Themes
by SLGray Today at 01:08

» User - Made Creations
by SLGray Today at 01:07

» Search box only visible on hover
by SLGray Today at 00:58

» Browsers & Updates
by SLGray Today at 00:56

» Change newposts/no new posts/ locked icons
by T.C. Yesterday at 19:52

» [HELP] About Profile Cover Code
by MaHwOs Sun 19 Nov 2017, 18:54

» bloquer un membre
by berlingo Fri 17 Nov 2017, 18:19

» IconSkouliki Graphics
by skouliki Fri 17 Nov 2017, 03:54

» [IN PROGRESS] Can this code work on pun version
by skouliki Thu 16 Nov 2017, 03:50

» [TUTORIAL] [ALL VERSIONS] Warning before posting
by demon99 Wed 15 Nov 2017, 08:12

» About Add Reply & New Topic button (popup form)
by omarpop23 Mon 13 Nov 2017, 20:31

» Add a login popup for the toolbar
by Ape Sun 12 Nov 2017, 18:41

» Post a message automatically when locking a topic
by ThunderTB Sun 12 Nov 2017, 13:51

Recent Tutorials
Who is online?
In total there are 6 users online :: 0 Registered, 0 Hidden and 6 Guests :: 2 Bots

None

[ View the whole list ]


Most users ever online was 172 on Fri 19 Feb 2016, 05:17

Shades on post

View previous topic View next topic Go down

avatar
Kisskiss

Title :
Gender : Unspecified
Posts : 47
Points : 574
Reputation : 1
Language : Italian, spanish
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostKisskiss on Mon 22 Aug 2016, 14:32

I saw that now almost everyone entering the colorful shades in the topics of the staffer , but how? what's the JavaScript ?
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 22
Posts : 4712
Points : 9587
Reputation : 2341
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Mon 22 Aug 2016, 15:59

Hi @Kisskiss,

I'm not sure I comprehend, could you perhaps try explaining with a screenshot ?
avatar
Kisskiss

Title :
Gender : Unspecified
Posts : 47
Points : 574
Reputation : 1
Language : Italian, spanish
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostKisskiss on Mon 22 Aug 2016, 16:05

avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1699
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Mon 22 Aug 2016, 16:17

Hello @Kisskiss,

Do you mean the Staff background with the orange font behind the text or the bar over the message text?

--------

avatar
Kisskiss

Title :
Gender : Unspecified
Posts : 47
Points : 574
Reputation : 1
Language : Italian, spanish
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostKisskiss on Mon 22 Aug 2016, 16:21

Staff background with the orange font behind the text
avatar
Teo!

Title :
Gender : Unspecified
Posts : 47
Points : 589
Reputation : 17
Language : Italian
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostTeo! on Mon 22 Aug 2016, 17:13

Hello @Ange Tuteur @Kisskiss

In the rank
Code:
<span class="staff-rank">RANK </span>

In the Javascript
Code:
$(function() {
  $('.post:has(.staff-rank)').addClass('staff-post');
});

In the CSS
Code:
.post.staff-post {
  background-image:url(http://i39.servimg.com/u/f39/18/21/41/30/f6011.png);
  background-repeat:no-repeat;
  background-position:left bottom;
}


However , I can not understand why the code problems to the theme, look in the editor




avatar
Kisskiss

Title :
Gender : Unspecified
Posts : 47
Points : 574
Reputation : 1
Language : Italian, spanish
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostKisskiss on Tue 23 Aug 2016, 15:25


@teo you're right! @Ange Tuteur can it be solved?
Thanks
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 22
Posts : 4712
Points : 9587
Reputation : 2341
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Tue 23 Aug 2016, 15:37

@Teo! @Kisskiss, could you provide a URL for the forum this is installed on ? I cannot seem to replicate the issue. Think
avatar
Teo!

Title :
Gender : Unspecified
Posts : 47
Points : 589
Reputation : 17
Language : Italian
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostTeo! on Tue 23 Aug 2016, 15:40


But I had to remove the codes . if it helps put them back !


www.ilforumditutti.net
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 22
Posts : 4712
Points : 9587
Reputation : 2341
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Thu 25 Aug 2016, 13:13

@Teo! sorry I almost forgot about this. Shocked

I have a question : Did you add the CSS at the top or bottom of the stylesheet ?
avatar
Teo!

Title :
Gender : Unspecified
Posts : 47
Points : 589
Reputation : 17
Language : Italian
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostTeo! on Thu 25 Aug 2016, 13:34

I add the CSS in the stylesheet!
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 22
Posts : 4712
Points : 9587
Reputation : 2341
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Thu 25 Aug 2016, 13:41

I know that, but did you place the codes at the TOP or BOTTOM of the stylesheet ? The placement of the code is important. Think
avatar
Teo!

Title :
Gender : Unspecified
Posts : 47
Points : 589
Reputation : 17
Language : Italian
Browser : Browser : Google Chrome Forum Version : Forum Version : punBB
Awards :
View all awards
View user profile

PostTeo! on Thu 25 Aug 2016, 14:01

Ohhh... at the TOP
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 22
Posts : 4712
Points : 9587
Reputation : 2341
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Thu 25 Aug 2016, 14:03

Try placing it at the BOTTOM of the stylesheet. If you place CSS at the top before the @import rules, it'll cause errors.

View previous topic View next topic Back to top

Create an account or log in to leave a reply

You need to be a member in order to leave a reply.

Create an account

Join our community by creating a new account. It's easy!


Create a new account

Log in

Already have an account? No problem, log in here.


Log in

 
Permissions in this forum:
You cannot reply to topics in this forum