Latest topics
» [GAME] What are you thinking right now?
by universecat Yesterday at 21:46

» [GAME] Animal Game
by universecat Yesterday at 21:43

» [GAME] Count to 1000 using even numbers Van-Helsing Edition
by universecat Yesterday at 21:40

» [GAME] Count to One Million!
by universecat Yesterday at 21:40

» [GAME] Last Letter Game
by universecat Yesterday at 21:39

» [GAME] Post a random picture
by SLGray Yesterday at 16:28

» Dark Mode + Another Question
by Ace 1 Yesterday at 13:31

» Hi everyone!
by skouliki Yesterday at 02:01

» Hai Guys~
by skouliki Yesterday at 01:59

» Add a login popup for the toolbar
by Ape Sun 15 Oct 2017, 13:51

» Mobile Usability Test
by Ange Tuteur Sat 14 Oct 2017, 11:20

» Chit Chat Thread
by Ange Tuteur Sat 14 Oct 2017, 11:20

» [GAME] World Snake
by SLGray Thu 12 Oct 2017, 16:12

» [GAME] Never have I ever..
by Valoish Thu 12 Oct 2017, 13:01

» Browsers & Updates
by SLGray Mon 09 Oct 2017, 12:11

Recent Tutorials
Who is online?
In total there are 11 users online :: 0 Registered, 0 Hidden and 11 Guests

None

[ View the whole list ]


Most users ever online was 172 on Fri 19 Feb 2016, 05:17

Weird chatbox text

View previous topic View next topic Go down

avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Wed 17 Aug 2016, 15:01

Hey @Ange Tuteur,

I am not sure whether this is a bug or some of my errors. During the latest update, before the update you released to us, i never activated the chat to actually check it. So before the update of the FAE when i hovered the chat line to see the active users, if there were none it said There are no users currently ONLINE or something like that. Now it only says ONLINE.
http://prntscr.com/c6zeyn

Is this something like a bug or is it just my forum?


Last edited by Luffy on Sun 04 Sep 2016, 03:43; edited 2 times in total

--------

avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Wed 17 Aug 2016, 16:17

Hi @Luffy,

Thanks for bringing this to me. Doff

From what I can tell, everything seems to be okay on my end + on newly installed forums, so it may only be your forum. Did you make any modifications or replace anything in the CSS recently ?

BTW the default CSS looks like :
Code:
#chatbox_members > ul.online-users:empty:after { content:"No members are currently online."; }
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Wed 17 Aug 2016, 18:50

Yeah this is not what it has in my CSS. As long as it's not a bug from the new update installation it's okay on my end.
I just have started working on the CSS so i didn't change anything. That's why i asked here just in case someone else has the same problem! Smile

--------

avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Wed 17 Aug 2016, 18:57

Regardless it's a weird development, it could have been an after effect from a temporary translation change or some other bug I'm not aware of.. most likely from an update, but I checked the CSS here and it's okay. Think

Unfortunately I'm not sure what caused it Dx
avatar
Guest
Guest
View all awards

PostGuest on Wed 17 Aug 2016, 18:59

@Ange Tuteur: just a wild guess, but could it be the cookie time-out doing that before it refreshed the status?
avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Wed 17 Aug 2016, 19:04

@Samantha nah, the text for the chatbox is in the CSS. The only stuff that modifies the CSS on FAE is :
- Updates
- Translations
- Theme Management
- General Settings (Coming soon..)
- Humans

There's a lot of variables, so I'm not sure which one changed the CSS text for his chatbox. Think
avatar
Guest
Guest
View all awards

PostGuest on Wed 17 Aug 2016, 19:05

Ange Tuteur wrote:@Samantha nah, the text for the chatbox is in the CSS. The only stuff that modifies the CSS on FAE is :
- Updates
- Translations
- Theme Management
- General Settings (Coming soon..)
- Humans

There's a lot of variables, so I'm not sure which one changed the CSS text for his chatbox. Think

Oh, well, yk I'm not a fan of standard FM chat Razz
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Wed 17 Aug 2016, 19:13

The default one shows the emoticons and the color to change the text or not? Because on mine it's just the message box and send.. For some reason.. Think

--------

avatar
Guest
Guest
View all awards

PostGuest on Wed 17 Aug 2016, 19:15

Sounds like you 're hiding the chatbox and are using the /chatbox link instead...
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Wed 17 Aug 2016, 19:23

But i am not only using the /chatbox.
http://prntscr.com/c72tm4

--------

avatar
Guest
Guest
View all awards

PostGuest on Wed 17 Aug 2016, 19:27

So, do you see the colors if you expand the chatbox using this button by dragging it down? http://prntscr.com/c72uyy
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Wed 17 Aug 2016, 19:38

@Samantha no because that doesn't resize the chatbox. That simply doesn't work...

--------

avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Wed 17 Aug 2016, 20:13

@Luffy it might be related to the chatbox responsiveness. Since it's in a separate window it takes the width of that window into account. Think

Try finding this part in the CSS :
Code:
  /* CHATBOX */
  label[for="message"] { display:none; }
  #message { width:80%; }
  #submit_button {
    width:15%;
    float:right;
  }

  #chatbox { bottom:80px; }
  #chatbox_footer { height:80px !important; }
  #chatbox_footer .style-buttons {
    display:block;
    float:none;
  }
and comment it out / remove it to see if that's your problem

It's under :
Code:
/* -- 23. RESPONSIVENESS -- */
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Thu 18 Aug 2016, 03:05

There was a float:none to the .right-box element and that's why the bold and other buttons didn't show up. I fixed that but i still want either the default chatbox or take the away list under the online list and the messages of the members to go to the right side.

Can we do that @Ange Tuteur?

--------

avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Thu 18 Aug 2016, 12:31

I see. I'm not sure what you mean by the last part, but the CSS that styles and manipulates the position of the Chatbox elements can be found in "22. CHATBOX" :
Code:
/* -- 22. CHATBOX -- */
body.chatbox { background-color:#FFF; }

#chatbox_members, #chatbox_members:after, #chatbox { transition:200ms; }
#chatbox_header, #chatbox_footer, #chatbox_members, #chatbox {
  position:absolute;
  left:0;
  right:0;
}

#chatbox_header { top:0; }
#chatbox_footer { bottom:0; }
#chatbox_header, body #chatbox_footer {
  color:#FFF;
  background:#69C;
  height:40px;
  line-height:40px;
  padding:0 3px;
  overflow:hidden;
}

#chatbox_header a { color:#FFF; }

.chatbox-title, .chatbox-options li { float:left; }
.chatbox-options { float:right; }
.chatbox-options li { list-style-type:none; }

/* buttons */
body #divcolor { line-height:15px; }
#divsmilies > img { vertical-align:middle; }
#divcolor, #divsmilies, #help-button, #submit_button, .format-message + label {
  margin:8px 1px 0 1px;
  cursor:pointer;
  overflow:hidden;
}

.text-field { padding-left:6px; }
#message, body #submit_button {
  height:auto;
  padding:3px;
}

/* messages */
#chatbox {
  top:70px;
  bottom:40px;
  padding:3px;
  overflow:hidden;
  overflow-y:auto;
  border:1px solid #69C;
}

body #chatbox > p {
  margin:3px 0;
  border:none;
}

/* member lists */
#chatbox_members {
  top:40px;
  height:30px;
  overflow:hidden;
  border-left:1px solid #69C;
  border-right:1px solid #69C;
}

#chatbox_members:after {
  content:"Hover over to see who is online.";
  color:#FFF;
  font-size:16px;
  line-height:30px;
  text-align:center;
  background:rgba(0, 0, 0, 0.3);
  position:absolute;
  top:0;
  left:0;
  right:0;
  bottom:0;
  opacity:1;
}

#chatbox_members > h4 {
  color:#FFF;
  background:#69C;
  position:absolute;
  top:0;
  left:0;
  width:50%;
  height:30px;
  line-height:30px;
  text-align:center;
  display:block !important;
}

#chatbox_members > h4.online { background:#8B5; }
#chatbox_members > h4.away {
  background:#E53;
  border-left:1px solid #69C;
  left:auto;
  right:0;
}

#chatbox_members > ul {
  position:absolute;
  top:30px;
  left:0;
  width:50%;
  height:120px;
  overflow:hidden;
  overflow-y:auto;
}

#chatbox_members > ul:empty:after {
  content:"";
  display:block;
  padding:3px;
  text-align:center;
}

#chatbox_members > ul.away-users:empty:after { content:"No members are currently away."; }
#chatbox_members > ul.online-users:empty:after { content:"No members are currently online."; }

#chatbox_members > ul.away-users {
  border-left:1px solid #69C;
  left:auto;
  right:0;
}

#chatbox_members > ul > li { padding:3px; }
#chatbox_members li span { cursor:pointer; }

#chatbox_members:hover + #chatbox { top:190px; }
#chatbox_members:hover { height:150px; }
#chatbox_members:hover:after {
  opacity:0;
  visibility:hidden;
}

body #chatbox_contextmenu {
  background:#FFF;
  border:1px solid #CCC;
  padding:3px;
  min-width:100px;
}

/* embedded chatbox */
.panel #chatbox_bottom, .panel #chatbox_top {
  height:400px !important;
}

/* cb-avatar */
body #chatbox .cb-avatar {
  border:2px solid #69C !important;
  box-shadow:none;
}

body #chatbox .cb-avatar, body #chatbox .cb-avatar img {
  height:34px;
  width:34px;
}
avatar
Luffy

Title :
Information Master
Gender : Male
Age : 23
Posts : 291
Points : 1664
Reputation : 64
Language : Greek, English
Browser : Browser : Google Chrome Forum Version : Forum Version : phpBB3
Awards :
View all awards
View user profile https://www.inforumgr.com/ https://www.facebook.com/inforumgr https://twitter.com/inforumgr

PostLuffy on Sun 04 Sep 2016, 03:43

Thank you! This is now solved! Smile

--------

avatar
Ange Tuteur
Administrator
Title :
Coffee Addict
Gender : Male
Age : 21
Posts : 4698
Points : 9534
Reputation : 2337
Location : Macungie, PA
Language : EN10, FR5
Browser : Browser : Brave Forum Version : Forum Version : Forumactif Edge
Awards :
View all awards
View user profile https://github.com/SethClydesdale https://twitter.com/sethc1995

PostAnge Tuteur on Mon 05 Sep 2016, 14:35

No problem, thanks for letting me know it's solved. ^^

Archived

Have a good day. Smile

View previous topic View next topic Back to top

Create an account or log in to leave a reply

You need to be a member in order to leave a reply.

Create an account

Join our community by creating a new account. It's easy!


Create a new account

Log in

Already have an account? No problem, log in here.


Log in

 
Permissions in this forum:
You cannot reply to topics in this forum